Contact Us Follow us on Twitter Follow us on Linkedin
Update:  We have decided to push to this to Monday (10/3/2016 m/d/y) to prevent any issues over the weekend.  


Update:  Due to 5.2 and 5.3 using diferent password hashes for database connections and a number of customers using 5.2 with databases, we have extended the switchover to October 1, 2016.

If you are using 5.2 and a database, please change your php to at least 5.3 and update the mysql user's password hash as described in https://u2-web.com/knowledgebase/119/Selecting-PHP-version.html .


We have updated our shared web services with the following changes. Some changes will require you to take action – see below.

1) Added apache 2.4 as a backend web server, with the current apache 2.2 in place

2) Added php-fpm on all php version (php 5.3 and up)

3) Added PHP 7.0 .

4) Added better opcache support for php 5.5 and up

5) Paypal TLS / Authorize.net – see below

What does this mean to you:

Apache 2.4 and php-fpm use what are called “workers” or threads to serve each request. Previous versions would spin up a process for each request. The spin up time can delay requests, though usually not by much. Php-fpm resolves that spin up delay by having dedicated workers for each site. This also allows us to provide more workers to sites that are under a unusually heavy load.

What do you need to do:

On 9/1/2016 (september 1, 2016), the current configuration will be replaced with the above web services. This means that the minimal php version will be 5.3, however, later this year or early next php 5.3 will also be phased out. Php 5.2 has been end of life for many years and 5.3 is also reaching that same point. As many customers have depended on 5.2, we have kept it this long. Furthermore, the default php version on the server will be php 5.3, even if you have php 5.2 selected or used in scheduled tasks / cron jobs.

If you are using php 5.2, you need to confirm with your script developers if php 5.3 or above will work for your script before the switch. Most scripts will work fine with 5.3, however, you would need to double check.

If you are already using php 5.3 or above, go ahead and test out the configuration (see below).

How to test the new configuration before switch:

Place the file called “.useApache24” in the domain's directory via your FTP client and wait 10 minutes. If your site is working, then there is nothing else to do. If it gives a database error, reset the database user's password via the control panel. If it does not work, remove the .useApache24 files and fix the compatibility issue

To use PHP 7, place a file called “.usePHP7” in your domain's directory and wait 10 minutes. Reload your site and see if it is working. Check a phpinfo() output to confirm the version did change.  At this time php 5.6 has been skipped, however, if enough demand for it is given it will be added. 

Paypal TLS / Authorize.net

The new configurations work with Paypal TLS and authorize.net changes that are upcoming on their side without additional changes, however, php 5.5 is required. On the legacy configuration, you need to specify the TLS version in your script's code where it calls curl.

If you have any questions on the above geek speak, please let us know. 



Wednesday, June 15, 2016

« Back